October 4, 2017

Konfigurasi Telnet dan SSH di Cisco

A. PENGERTIAN

Konfigurasi Telnet

Telnet (Telecommunication network) adalah sebuah protokol jaringan yang digunakan pada Internet atau Local Area Network untuk menyediakan fasilitas komunikasi berbasis teks interaksi dua arah yang menggunakan koneksi virtual terminal.

B. LATAR BELAKANG

Meremote switch dan router di packet tracer

C. MAKSUD DAN TUJUAN

Ingin mengimplementasikanya di dunia kerja dan mengulangi Materi yang diberi tentang ssh dan telnet

D. TAHAPAN PEKERJAAN

TELNET Berikut Topology Telnet :

Linux, Unix, BSD, MacOS, Komunitas Pengguna Linux Indonesia, KPLI Klaten, KPLI Bulukumba, MikroTik, MikroTik Indonesia, FreeBSD, FreeBSD Indonesia, Cisco, Cisco Indonesia, BLC Telkom Klaten, Ansible, Nginx, Apache2, Caddy Server, Ayo Belajar Linux, Cloud Computing, e-Learning, Open edX, Proxmox, Sendy, Microsoft SQL Server, MySQL, PostgreSQL, Lets Encrypt, Case Study, Atlassian, Virtualization, Faizar Septiawan, Icar, siBunglonGanteng, siBunglonLabs, Orang Ganteng

  1. Pertama, masukkan default gateway yang terdapat pada Router, Disini saya Memberikan IP Address pada interface fastEthernet 0/0 adalah 192.168.32.1. lalu saya memberikan contoh password priveleged level (#) : okta

Perintahnya adalah :

> Router>enable  
> Router#configure terminal  
> Router(config)#enable secret 1234  
> Router(config)#interface fastEthernet 0/0  
> Router(config-if)#ip address 192.168.32.1 255.255.255.0  
> Router(config-if)#no shutdown  
> Router(config-if)#exit  
> Router(config)#line vty 0 4  
> Router(config-line)#login local  
> Router(config-line)#exit  
> Router(config)#username okta password 1234  
> Router(config)#service password-encryption  
> Router(config)#exit

Linux, Unix, BSD, MacOS, Komunitas Pengguna Linux Indonesia, KPLI Klaten, KPLI Bulukumba, MikroTik, MikroTik Indonesia, FreeBSD, FreeBSD Indonesia, Cisco, Cisco Indonesia, BLC Telkom Klaten, Ansible, Nginx, Apache2, Caddy Server, Ayo Belajar Linux, Cloud Computing, e-Learning, Open edX, Proxmox, Sendy, Microsoft SQL Server, MySQL, PostgreSQL, Lets Encrypt, Case Study, Atlassian, Virtualization, Faizar Septiawan, Icar, siBunglonGanteng, siBunglonLabs, Orang Ganteng

  1. Setelah Konfig Router Selesai, Selanjutnya kita Konfig Switch, sebagai contoh saya memberikan IP Address vlan1 yaitu : 192.168.32.2, karna 192.168.32.1 adalah gateway untuk router. Saya memberikan password pada switch privileged lever (#) : okta
> Switch>enable  
> Switch#configure terminal  
> Switch(config)#vlan 1  
> Switch(config-vlan)#interface vlan 1  
> Switch(config-if)#ip address 192.168.32.2 255.255.255.0  
> Switch(config-if)#exit
> Switch(config)#ip default-gateway 192.168.32.1
> Switch(config)#enable secret okta  
> Switch(config)#line vty 0 4  
> Switch(config-line)#login local  
> Switch(config-line)#exit  
> Switch(config)#username okta password 1234  
> Switch(config)#service password-encryption

Linux, Unix, BSD, MacOS, Komunitas Pengguna Linux Indonesia, KPLI Klaten, KPLI Bulukumba, MikroTik, MikroTik Indonesia, FreeBSD, FreeBSD Indonesia, Cisco, Cisco Indonesia, BLC Telkom Klaten, Ansible, Nginx, Apache2, Caddy Server, Ayo Belajar Linux, Cloud Computing, e-Learning, Open edX, Proxmox, Sendy, Microsoft SQL Server, MySQL, PostgreSQL, Lets Encrypt, Case Study, Atlassian, Virtualization, Faizar Septiawan, Icar, siBunglonGanteng, siBunglonLabs, Orang Ganteng

Setelah Melakukan Konfig pada Switch, sekarang kita pergi ke PC dan mengatur IP Address PC dengan IP Address “192.168.32.3”

Linux, Unix, BSD, MacOS, Komunitas Pengguna Linux Indonesia, KPLI Klaten, KPLI Bulukumba, MikroTik, MikroTik Indonesia, FreeBSD, FreeBSD Indonesia, Cisco, Cisco Indonesia, BLC Telkom Klaten, Ansible, Nginx, Apache2, Caddy Server, Ayo Belajar Linux, Cloud Computing, e-Learning, Open edX, Proxmox, Sendy, Microsoft SQL Server, MySQL, PostgreSQL, Lets Encrypt, Case Study, Atlassian, Virtualization, Faizar Septiawan, Icar, siBunglonGanteng, siBunglonLabs, Orang Ganteng

Setelah Selesai, Pergi ke Command Prompt > telnet (Nomer Ip yang dituju) misal saya ingin Telnet ke Router, Berarti “telnet 192.168.32.1”

Linux, Unix, BSD, MacOS, Komunitas Pengguna Linux Indonesia, KPLI Klaten, KPLI Bulukumba, MikroTik, MikroTik Indonesia, FreeBSD, FreeBSD Indonesia, Cisco, Cisco Indonesia, BLC Telkom Klaten, Ansible, Nginx, Apache2, Caddy Server, Ayo Belajar Linux, Cloud Computing, e-Learning, Open edX, Proxmox, Sendy, Microsoft SQL Server, MySQL, PostgreSQL, Lets Encrypt, Case Study, Atlassian, Virtualization, Faizar Septiawan, Icar, siBunglonGanteng, siBunglonLabs, Orang Ganteng

keterangan :

  • line vty 0 4 : adalah cara untuk mengaktifkan telnet 4 koneksi
  • service password-encription : untuk mengekripsi semua password

SSH

Linux, Unix, BSD, MacOS, Komunitas Pengguna Linux Indonesia, KPLI Klaten, KPLI Bulukumba, MikroTik, MikroTik Indonesia, FreeBSD, FreeBSD Indonesia, Cisco, Cisco Indonesia, BLC Telkom Klaten, Ansible, Nginx, Apache2, Caddy Server, Ayo Belajar Linux, Cloud Computing, e-Learning, Open edX, Proxmox, Sendy, Microsoft SQL Server, MySQL, PostgreSQL, Lets Encrypt, Case Study, Atlassian, Virtualization, Faizar Septiawan, Icar, siBunglonGanteng, siBunglonLabs, Orang Ganteng

Melanjutkan topologi sebelumnya, karena jalur telnet menggunakan clear text yang berarti jalur yang lewat masih bisa dilihat (tidak aman), maka untuk mengamankan jalur remot ini bisa menggunakan SSH (Secure Shell).

Yang diperhatikan untuk membuat SSH adalah :
-) Hostname tidak boleh default

-) Harus ada domain name

-) Authentication nya menggunakan username dan password

-) Deskripsikan dijalur telnet bahwa akan menggunakan SSH

-) Generate Crypto Key.

Langsung saja kita konfig SSH pada CPT

  1. Config di Routernya: *Nama okta adalah contoh* kalian bisa menggunakan nama apapun terserah kalian.
> Router(config)#hostname okta  
> okta(config)#ip domain-name okta.com  
> okta(config)#crypto key generate rsa
> The name for the keys will be: okta.okta.com  
> Choose the size of the key modulus in the range of 360 to 2048 for your  
> General Purpose Keys. Choosing a key modulus greater than 512 may take  
> a few minutes.

Pada bagian perintah “crypto key generate rsa” akan ditanyakan berapa panjang bit yang ingin dimasukkan, pilihannya 512 dan maksimal 2048, itu menandakan panjang key datanya, semakin panjang key data akan semakin aman, tetapi semakin membebani perangkat, jika hanya unntuk belajar gunakan yang 512 saja.

> How many bits in the modulus [512]: 1024  
> % Generating 512 bit RSA keys, keys will be non-exportable...[OK]

Linux, Unix, BSD, MacOS, Komunitas Pengguna Linux Indonesia, KPLI Klaten, KPLI Bulukumba, MikroTik, MikroTik Indonesia, FreeBSD, FreeBSD Indonesia, Cisco, Cisco Indonesia, BLC Telkom Klaten, Ansible, Nginx, Apache2, Caddy Server, Ayo Belajar Linux, Cloud Computing, e-Learning, Open edX, Proxmox, Sendy, Microsoft SQL Server, MySQL, PostgreSQL, Lets Encrypt, Case Study, Atlassian, Virtualization, Faizar Septiawan, Icar, siBunglonGanteng, siBunglonLabs, Orang Ganteng

Berikut ini untuk menampilkan hasil encripsi key :

okta(config)#do sh crypto key mypubkey rsa

Perintah diatas adalah script untuk menampilkan hasil encripsi key. Setelah memasukkan script itu akan tampil tampilan seperti dibawah ini :

> % Key pair was generated at: 1:51:58 UTC Mar 1 1993  
> Key name: okta.okta.com  
> Storage Device: not specified  
> Usage: General Purpose Key  
> Key is not exportable.  
> Key Data:  
> 00002215 00004659 00002db4 00004762 00006688 00007238 00004ab3 000069ca  
> 0000015c 000050d6 000001c9 00002afd 00006ca7 00005b84 0000704e 000056ff  
> 00001831 0000077b 000028ea 00001ee9 00007579 000031ce 00003fb4 0484  
> % Key pair was generated at: 1:51:58 UTC Mar 1 1993  
> Key name: okta.okta.com.server  
> Temporary key  
> Usage: Encryption Key  
> Key is not exportable.

Linux, Unix, BSD, MacOS, Komunitas Pengguna Linux Indonesia, KPLI Klaten, KPLI Bulukumba, MikroTik, MikroTik Indonesia, FreeBSD, FreeBSD Indonesia, Cisco, Cisco Indonesia, BLC Telkom Klaten, Ansible, Nginx, Apache2, Caddy Server, Ayo Belajar Linux, Cloud Computing, e-Learning, Open edX, Proxmox, Sendy, Microsoft SQL Server, MySQL, PostgreSQL, Lets Encrypt, Case Study, Atlassian, Virtualization, Faizar Septiawan, Icar, siBunglonGanteng, siBunglonLabs, Orang Ganteng

Sekarang kita kembali ke PC dan pergi ke “Command Prompt”

Linux, Unix, BSD, MacOS, Komunitas Pengguna Linux Indonesia, KPLI Klaten, KPLI Bulukumba, MikroTik, MikroTik Indonesia, FreeBSD, FreeBSD Indonesia, Cisco, Cisco Indonesia, BLC Telkom Klaten, Ansible, Nginx, Apache2, Caddy Server, Ayo Belajar Linux, Cloud Computing, e-Learning, Open edX, Proxmox, Sendy, Microsoft SQL Server, MySQL, PostgreSQL, Lets Encrypt, Case Study, Atlassian, Virtualization, Faizar Septiawan, Icar, siBunglonGanteng, siBunglonLabs, Orang Ganteng

Setelah terbuka masukkan script “ssh –l okta 192.168.32.1”

karna saya menggunakan username “okta” pada router maka seletah “–l” kalian masukkan username kalian yang kalian konfig di router. Password pun sama, masukkan password yang kalian setting di router.Setelah terbuka masukkan script “ssh –l okta 192.168.32.1”

karna saya menggunakan username “okta” pada router maka seletah “–l” kalian masukkan username kalian yang kalian konfig di router. Password pun sama, masukkan password yang kalian setting di router.

Linux, Unix, BSD, MacOS, Komunitas Pengguna Linux Indonesia, KPLI Klaten, KPLI Bulukumba, MikroTik, MikroTik Indonesia, FreeBSD, FreeBSD Indonesia, Cisco, Cisco Indonesia, BLC Telkom Klaten, Ansible, Nginx, Apache2, Caddy Server, Ayo Belajar Linux, Cloud Computing, e-Learning, Open edX, Proxmox, Sendy, Microsoft SQL Server, MySQL, PostgreSQL, Lets Encrypt, Case Study, Atlassian, Virtualization, Faizar Septiawan, Icar, siBunglonGanteng, siBunglonLabs, Orang Ganteng

E. REFERENSI

ccnav6.com